S’abonner

Applet et JRE > 1.7.0_20

A partir de la JRE 1.7.0_21, des restrictions de sécurité ont été ajoutées et peuvent empêcher l'exécution de nos Applets. Si lors de l'utilisation d'une de nos Applets, celle-ci reste bloqué sur "Initialisation en cours...", vous devrez remplacer la version de LPAppletLoader.jar que vous utilisez par la dernière que nous vous fournissons.

Pour corriger ce problème il suffit de remplacer le fichier LPAppletLoader.jar déployé sur votre serveur par celui joint à cet article (version 3.1.0_02).

Cet article vous a-t-il été utile ?
Utilisateurs qui ont trouvé cela utile : 2 sur 2
Vous avez d’autres questions ? Envoyer une demande

4 Commentaires

  • 0
    Avatar
    SupProj

    A partir de Java 1.7.0_45, vous pourriez être confronté à ce genre de fenêtre:

    Sans_titre.png

     

    Ce problème est lié à des modifications au niveau des droits d’exécution des applets. Pour résoudre ce problème, vous devez utiliser une nouvelle version de LPAppletLoader (version 3.1.0_03).




    LPAppletLoader.jar
  • 0
    Avatar
    SupProj

    La version 1.7.0_25 est incompatible avec les applets utilisant LiveConnect: http://www.oracle.com/technetwork/java/javase/7u25-relnotes-1955741.html#lc-block  

    Si l'un de vos utilisateurs utilise cette version de JRE, il faudra lui faire procéder à une mise à jour avant de pouvoir utiliser une de nos applets. Dans le cas contraire, vous risquez de vous retrouver avec une barre de progression infini au chargement de l'applet avec LPAppletLoader.

  • 0
    Avatar
    SupProj

    Pour éviter la popup de sécurité suivante (fenêtre lié au LiveConnect pour l'update 1.7.0_45 de Java)

     tt.png

     

    Une nouvelle version de LPAppletLoader (3.2.0_01) a été mise en place. Cette version se compose de 2 fichiers JAR (LPAppletLoader.jar et LPAppletLoader_45.jar) ainsi que d'un nouveau LPAppletLoader.js. Pour utiliser cette version dans vos applets, il sera donc nécessaire de placer ces 3 fichiers en remplacement des anciens (LPAppletLoader.jar et LPAppletLoader_45.jar dans le même répertoire).

    Le nouveau code JS bloque par la même occasion l'utilisation des JRE 1.7.0_25 et 1.7.0_40 inutilisables avec les applets.

     




    LPAppletLoader.zip
  • 0
    Avatar
    SupProj

    Java version 1.7.0_51, apporte son lot de modification; dont une modification concerne l'utilisation des sockets. Un utilisateur utilisant un proxy et cette version de Java pourrait être incapable d'utiliser l'applet. 

    Pour résoudre ce problème veuillez utiliser cette nouvelle version de LPAppletLoader.js




    LPAppletLoader.js
Cet article n'accepte pas de commentaires.